Archisketch Forums

My device can't be resetted and suddenly can't be turned off

Hi, i was doing some level measurement, and suddenly the laser stopped, but the LED still blue, device disconnected from phone and can’t be turned off, reset button seems can’t be pressed, or is it normal that it is very hard like it is stuck?

Hello, alvinsoe.

Thank you for the message.

Yes, reset button is there for cases like yours.

It is hard to make sure it was clicked.

You need a sharp pin or straightened ned of a clip to click it.
You would feel a “click” when it is properly pressed.

Let us know once you tried it.

Thank you.

Tried the reset button until it clicked, double cheked it to make sure. Still can’t charge now, no LED, not able to turn on the device. What can i do?

Hello, alvinsoe.

Thank you for the information.

So now, you cannot power on the device, and also there’s no led light when connected to the charger, right?

If that’s the case, we assume it is hardware failure.
We’ll let you know when we are ready with return and exchange procedure.

Thank you.

Yes, that’s exactly what happened. Is there any timeline as for how long i must wait?

We plan to announce this Friday.

Thank you

Hi Archisketch team,

Do you announce something this Friday…? Seems i missed your announcement i’m affraid, can you direct me? Thank’s

Hi Archisketch team, still waiting for your update here… How is it?

Hello, alvinsoe.

We sent you a personal message.

Thank you.