Archisketch Forums

Device is undetectable

My device doesn’t show up in Bluetooth connections no matter how long I leave it on and right next to my iPhone XS or XS max or really any other device with Bluetooth. I have reset the device multiple times and turned Bluetooth on and off on each device. I have made sure all devices are fully charged.

Thanks for any help.

Hi Sean

For iOS phones you can not see the device in the Bluetooth list on your phone. But when you press the “Connect” button in the application and accept the application’s use of Bluetooth, the device should automatically connect.

Ah I was following the guide and assumed it would be the same for android or IOS.

Regardless, when I hit the connect button in the app, it fails almost instantly every time and offers a retry or exit. ‘Retry’ also just closes the window and nothing happens.

Hi Sean

Okay. We are releasing a new update later today, which should fix some problems regarding Bluetooth. If you after that release still have problems, please notify us again, and we will have a look at it as soon as possible.

And you should also turn on location service on your phone in order for Bluetooth to work, if you have not done that.

Device still doesn’t show up after update, I deleted and reinstalled the app- but it does not recognise my account anymore, also the email signup page offers no way of proceeding once data is entered.

Hi Sean

We have realized the problem with missing Sign-up finishing, and we are trying to fix that as soon as possible.

For the Bluetooth issue, can you try the following:

  1. Find your phone’s model number and write it here. You can see how to, in this link:

https://www.iphonelife.com/content/what-kind-iphone-do-i-have-all-iphone-generations-their-model-numbers

  1. Try to download the LightBlue app: https://itunes.apple.com/us/app/lightblue-explorer/id557428110?mt=8
    And let us know if you can detect the device using this application.

Regards

Model:

MT522X/A
A2101

The LightBlue app does allow me to see the device, and enables the laser automatically. As soon as I close the LightBlue app the device disconnects. I have tried a few different ways of opening the archisketch app and trying to connect the device while LightBlue is actively connected, but with no success

Hi Sean

Thanks for your response. When you press the Connect button in the Archisketch App, then nothing happens?, or do you receive a pop up or error message?

The same as before, “no device found” retry or exit

Okay. It might be a problem with a Time Out we have in our application. We will try to increase that and release a new update today.

Did an update, didn’t seem to do anything.

Anything else for me to try? Any update on the situation?

Hi.

We released a new update yesterday. Can you try to see if it solved your problem?

Updated the app, now it just stays on the ‘measurement’ and ‘space capture’ screen (screenshot attached) and still doesn’t find the device. image

So you do not get the error message saying that you should connect to Bluetooth device? When you say it stays on the page, do you mean that if you click Measurement and Space Capture, then nothing happens? You are only able to see that it is connected, after clicking one of those.

Ok that needs to be explained better in the UI, that after you click connect, the app should give you feedback and show connection and then that the user is expected to choose and option. Regardless neither option does anything for me.
Also, my device barely fits into the cradle and is wobbly.

Hi Sean

We just have a couple of questions to fully understand the problem.

  1. Regarding the phone that barely fits the device, is it the iPhone XS MAX or iPhone XS?

  2. Regarding the Bluetooth connection is it correct, that your problem is as follows:

  • You click the “Connect” button.
  • You are taken to the page with “Measure” and “Capture” buttons - and NOT shown the “No Device Found” pop-up.
  • You click Measure or Capture.
  • You are taken to the Measure or Capture Feature, but the Laser of the device is not turned on.

Regarding the UI guide we will improve it based on our users experiences, so we will take the idea into account.

  1. I have a XS Max, but the normal XS wobbles loosely as well.

  2. I click connect and then it comes up with the measure and capture ‘buttons’ but neither were doing anything, but since my last restart they now continue onto the measurement or capturing screens.
    HOWEVER, the app isn’t accurate to the laser pointer because of the mechanical looseness. The two phones I’ve tested with wobble and the AR function then missaligns with the laser point.

Hi, Sean.

As you said, the AR guide will misalign with the laser if the device wobbles.

About that mechanical looseness,
is it at the hinge (where the holder closes and opens) that is loose?

If that’s the case, we would have to discuss the case with the hardware team.

Let us know and we will keep you supported.

Thank you.